cancel
Showing results for 
Search instead for 
Did you mean: 

BIOS medion S6426

New Voice
Message 1 of 19
689 Views
Message 1 of 19
689 Views

BIOS medion S6426

Hi


I own notebook medion S6426.

 

Last month I visited medion support site, entered MSN number searching for drivers and bios update.

There was listed bios update http://www.medion.com/gb/service/_lightbox/treiber_details.php?did=17813 .

Description says version 2.07, but when I updated downloaded bios, it was version 2.09.

 

Since bios update to version 2.09, there is no sound from internal speakers or connected headphones.

In device manager, there is no speakers listed, like it should be.

I even tried with restoring to factory defaults and that didn't fix it.

 

Since this unfortunate provided bios update, about a week later I again entered medion support with my MSN number searching for fixed bios update,

but this time there were(and is) no bios update listed. It looks like medion recognized that it was serving faulty bios update and delisted bios update.

 

Browsing medion forum, I stumbled on https://community.medion.com/t5/FAQs/BIOS-updates-concerning-the-Meltdown-Spectre-vulnerability-for/...

and again it shows bios version 207, but download bios is version 209

 

Where can I get bios update to fixed or previous version?

 

Thank you in advance

18 REPLIES
Superuser
Message 2 of 19
668 Views
Message 2 of 19
668 Views

Re: BIOS medion S6426

@lms2

 

Your given link for the Bios functions, and it shows Bios Version 2.09.

 

Please give us your MSN-number, because with S6426 (or S6425) no results show up, not in the english and not on the german Medion services pages.

 

Regards, daddle

New Voice
Message 3 of 19
660 Views
Message 3 of 19
660 Views

Re: BIOS medion S6426

Someone must have corrected the description, after I sent private message to users: Frog, Major_Tom and DarkKnight and opened this topic

 

I have proof: printscreen, google cache proof and saved site to archive.org

 

Am I speaking to an employee of Medion?

 

I just want posted link to fixed or original(I think it was 2.01 or maybe 2.03?) bios version.

 

 

Superuser
Message 4 of 19
651 Views
Message 4 of 19
651 Views

Re: BIOS medion S6426

@lms2

 

No, I am just a helpful user. And you and I don't need proof, I just gave you the info about what I found. 

You didn't tell you wrote PNs to the mods.This should belong to the informations given in the first post.

For a Bios-Link maybe @DarkKnight or @Luke can help you therewith.

And your MSN-number? Could be helpful.

 

regards, daddle

  

Community Manager
Message 5 of 19
634 Views
Message 5 of 19
634 Views

Re: BIOS medion S6426

Hi @lms2,

 

As @daddle  has already mentioned above, please provide the MSM number of your notebook

and (if available) it`s MD-number.

 

 

Thanks in advance,

Luke


MEDION AG - A Lenovo Company • Web: www.medion.de • Community: community.medion.com • Facebook: www.facebook.com/MEDIONDeutschland


Bitte belohne hilfreiche Antworten mit Kudos und markiere die beste Antwort/Lösung mit Als Lösung akzeptieren.
Highlighted
New Voice
Message 6 of 19
609 Views
Message 6 of 19
609 Views

Re: BIOS medion S6426

Medion AKOYA S6426
MSN 30024204

MD 61850

 

 

Using ubuntu I figured out problem, and yes bios needs to be fixed

 

Syslog from my laptop with updated bios

...

snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC269VC: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:line
snd_hda_codec_realtek hdaudioC0D0: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
snd_hda_codec_realtek hdaudioC0D0: hp_outs=0 (0x0/0x0/0x0/0x0/0x0)
snd_hda_codec_realtek hdaudioC0D0: mono: mono_out=0x0
snd_hda_codec_realtek hdaudioC0D0: dig-out=0x1e/0x0
snd_hda_codec_realtek hdaudioC0D0: inputs:
snd_hda_codec_realtek hdaudioC0D0: Front Mic=0x19
snd_hda_codec_realtek hdaudioC0D0: Rear Mic=0x18
snd_hda_codec_realtek hdaudioC0D0: Line=0x1a

...

 

but from my friends medion S6426(same just not yet with updated bios)

 

...

snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC269VC: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
snd_hda_codec_realtek hdaudioC0D0: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
snd_hda_codec_realtek hdaudioC0D0: hp_outs=1 (0x15/0x0/0x0/0x0/0x0)
snd_hda_codec_realtek hdaudioC0D0: mono: mono_out=0x0
snd_hda_codec_realtek hdaudioC0D0: inputs:
snd_hda_codec_realtek hdaudioC0D0: Mic=0x18
snd_hda_codec_realtek hdaudioC0D0: Internal Mic=0x12

...

 

In linux I can select unplugged line output(that should be speaker) and sound works with laptop speakers.

 

 

 

Please provide working bios link.

 

 

 

Community Manager
Message 7 of 19
517 Views
Message 7 of 19
517 Views

Re: BIOS medion S6426

Hello @lms2,

 

I´ve checked your request internally and got the answer that a downgrade to BIOS V2.07 is not possible

due to technical reasons.

 

Sorry,

Luke

 


MEDION AG - A Lenovo Company • Web: www.medion.de • Community: community.medion.com • Facebook: www.facebook.com/MEDIONDeutschland


Bitte belohne hilfreiche Antworten mit Kudos und markiere die beste Antwort/Lösung mit Als Lösung akzeptieren.
Community Manager
Message 8 of 19
493 Views
Message 8 of 19
493 Views

Re: BIOS medion S6426

Hello @lms2,

 

A quick addendum on this issue:

After discussing your problem with our technicians we really doubt it`s a BIOS issue. We`d rather

suggest to re-install the respective Ubuntu sound drivers.

 

Luke


MEDION AG - A Lenovo Company • Web: www.medion.de • Community: community.medion.com • Facebook: www.facebook.com/MEDIONDeutschland


Bitte belohne hilfreiche Antworten mit Kudos und markiere die beste Antwort/Lösung mit Als Lösung akzeptieren.
Newcomer
Message 9 of 19
452 Views
Message 9 of 19
452 Views

Re: BIOS medion S6426

Hi.

 

I have the same problem in the Medion Akoya P6687 - MD61006. After upgrade the BIOS at the latest version (same as lms2 user) the sound stop working. Reading in internet I'm pretty sure that the problem is that the BIOS have disabled the sound card. In Windows the Speakers are marked as "Unplugged".

 

It is the second laptop of that model the shop have sent me and in both cases is the same. Please, I encourage to Medion to ask InsydeH20 to provide a new BIOS software upgrade that solve that issue.

 

Thanks in advance.

 

Beginner
Message 10 of 19
142 Views
Message 10 of 19
142 Views

Re: BIOS medion S6426

Hello,

 

same problem here. Before bios update, no sound problems, after update no sound anymore.

 

*EDIT*

 I found the solution, maybe somebody in the future can use this:

Install pavucontrol (sudo apt install pavucontrol)

 

Open pavucontrol

Go to configuration

And select "Analog Stereo Duplex (unplugged)"

enter image description here

 

More information on: (works also on 18.04 LTS)

https://askubuntu.com/questions/998520/no-sound-in-ubuntu-17-10-with-intel-corporation-sunrise-point...

 

Thanks in advance,