cancel
Showing results for 
Search instead for 
Did you mean: 

Eraser Beast X25 Bios 1.26MED11

26 REPLIES 26
Pete748
Beginner
Message 1 of 27
2,183 Views
Message 1 of 27
2,183 Views

Eraser Beast X25 Bios 1.26MED11

Hey Folks,

I've just had windows push a BIOS (1.26MED11) update to my laptop.

 

Does anyone have the patch notes?

 

Thank you

 

Screenshot 2022-01-14 143954.png

26 REPLIES 26
agent-orangeCH
Trainee
Message 11 of 27
831 Views
Message 11 of 27
831 Views

Can you provide me the 1.19 Bios? I tried to flash 1.23 but didnt work directly within the device manager. So I guess I need a tool to do it.

 

If the sound would work again after that, I know its not sw/bios problem and not hw-related. Then I would disable the driver updates within Windows updates until they released a working bios.

Edit: Nevermind, the notebook just stopped working after I've restored Windows again. Now the monitor shows nothing anymore and the fans are running on full power for some minutes, then the notebook will reboot. I will send it back and buy something else that is working properly cause I have no time for this....

 

 

 

Ed

 

Schummi
Specialist
Message 12 of 27
789 Views
Message 12 of 27
789 Views

In the German community /https://community.medion.com/t5/ERAZER-Gaming/Erazer-Beast-X25-MD-63875-Fehlende-Funktionen-im-Contr...) we have tried something and fortunately it was successful.

 

1. Install DMI-Patch from here: https://www.medion.com/at/service/product-detail/30032959

2. Follow the FAQ: https://community.medion.com/t5/FAQs/How-do-I-get-back-missing-settings-options-in-Control-Center/ta...

 

The DMI-Patch is for RTX3080 platform only but in our test it solves the issue also on an RTX3070. If you are in doubt please wait for an official announcement.

Andi
Master Moderator
Message 13 of 27
739 Views
Message 13 of 27
739 Views

Hello everyone and thanks for the feedbacks.

 

On 13.01.2022 the BIOS Update 1.26 was released via Windows Update. Since then, some users report unwanted effects like:

 

- Graphics card works with significantly reduced performance
- System reacts slowly.
- Fans run too slowly
- audio playback doesn't work or doesn't work properly
- various settings in the Control Center disappeared (e.g. no turbo mode available)

 

Due to these reports, the BIOS was initially taken offline again. Our technical department is currently investigating the background. In order to localize the error as quickly as possible, our colleagues still need additional information. Therefore I ask ALL users, who can or could observe one or more of the above mentioned effects since the installation of the BIOS update, to inform me about the following information:

 

1. eight-digit part number (MSN) of the notebook
2. BIOS version before the update (if still known)
3. currently used version of the Control Center (readable in the settings under "Apps")
4. currently used version of the Control Center service (readable in the settings under "Apps")
5. what is the effect on your notebook?

 

The more feedback I get, the better. I will pass on the information accordingly.

 


Greetings - Andi


MEDION. LÄUFT BEI MIR.
• Web: www.medion.de • Community: community.medion.com • Facebook: MEDIONDeutschland • Instagram: @medion.de


Bitte belohne hilfreiche Antworten mit Kudos und markiere die beste Antwort/Lösung mit Als Lösung akzeptieren.
ThaMadden
New Voice
Message 14 of 27
726 Views
Message 14 of 27
726 Views

Andi,

as requested....

1. 30031487
2. Don't know
3. 3.33.4.0
4. Maybe missing something, but there is no such service on my machine? Can't find it at least
5. Losing the Realtek soundcard (no sound, no mic), disabled in Device Manager (see Hidden items); also, Turbo mode either from Control Center or from the physical button not available; At startup fans now run at top speed until Windows completely started, that wasn't the case before the update - it was completely quiet all thru startup

willopj
New Voice
Message 15 of 27
717 Views
Message 15 of 27
717 Views

Thanks Andi,

 

1. 30031969
2. Uncertain
3. 3.33.4.0
4. 3.1.4.0
5.

  • In-built audio not working (Speakers show up in device manager as "High Definition Audio Device", but no mention of Realtek - states the manufacturer is "Microsoft" rather than Realtek. Microphone does not show up at all in device manager / "No input device" in sound settings)
  • Fans not behaving reliably (might spin up aggressively during boot etc, but then when playing a game, not ramping up as it should)
  • Missing settings in control centre, completely non-sensical fan curve (also inability to change RGB colour to plain white... which would be nice)
  • Since the bios update, the machine no longer appropriately detected my secondary M.2 SSD that I bought - XPG Gammix s70 blade 1TB. It showed up as a 2GB rather than 1TB, with wrong name in BIOS. I have therefore since removed the SSD and am using the original SSD only (so machine in factory state). The new SSD was working originally, with correct name. I mention this in case the BIOS update has also impacted the PCI-E bus in some way.
  • There may be other things but I have been reluctant to use the machine as I do not want to cause damage by overheating with the sporadic fan curves...

 

edit: In addition thanks Schummi for sharing the advice on a fix. Seeing as though Medion are looking into it though I will wait for the official fix.

 

Andi, do you have any sort of time frame as to when they hope to release an official fix?

JvdEngel
Beginner
Message 16 of 27
703 Views
Message 16 of 27
703 Views

1. 30031235
2. don't know
3. 3.33.19.0
4. 3.33.21.0
5. missing settings in control center - fan's wont operate, only with fan boost option - sound isnt working (speakers and 3.5mm) - keyboard backlight settings only work after opening the settings in control center.

All started after the bios update

agent-orangeCH
Trainee
Message 17 of 27
651 Views
Message 17 of 27
651 Views

1. 30031674
2. don't know
3. don't know
4. don't know
5. First 3.5mm jack wasnt working, 2 days later the speaker stopped working. 1 Day later after I reinstalled Windows and updates were installed together with a firmware (again) the notebook stopped working. I can power it on, I hear the fans spin up to 100% and then it reboots. But no monitor signal, nothing.

I want to send this notebook to RMA and created a case but didnt hear anything since last week. Thats really poor customer-service!

 

 

 

Schummi
Specialist
Message 18 of 27
642 Views
Message 18 of 27
642 Views

Hi @Pete748  @Pete748 @willopj @JvdEngel  and everyone else,

we are still working on an solution that will fix all reported issues on all affected devices.

I just get aware that we already have a official information for the audio issue: https://community.medion.com/t5/FAQs/How-do-I-fix-faulty-audio-playback-on-my-ERAZER-Beast-X25/ta-p/...

We suggest to execute at least the linked DMI tool (oemservtool.exe) on all devices that still have issues after the BIOS update.

This DMI tool should bring the systems back in a more stable condition.

If you still have issues with your Control Center afterwards please give our FAQ a try: https://community.medion.com/t5/FAQs/How-do-I-get-back-missing-settings-options-in-Control-Center/ta...

 

Please feedback if you have any issues or open topics.

 

 

@agent-orangeCH: When you have no monitor signal anymore I am afraid that we cannot fix remotely. Maybe the BIOS update went wrong or has been interupted. Anyway, sorry for the bad experience

agent-orangeCH
Trainee
Message 19 of 27
635 Views
Message 19 of 27
635 Views

@Schummiyes, I also think so that during the Windows updates the bios update went wrong. Thats the only logical possibility in my opinion.

 

I'll hope that the Medion support contact asap so that I can send it to RMA.

 

slackbladder
Apprentice
Message 20 of 27
538 Views
Message 20 of 27
538 Views

I have problem with control centre. I had uninstalled and then reinstalled but it seems I uninstalled the wrong thing (should have been the service but I uninstalled the app) so when I tried the fix it didn’t work. I am now without a control centre and performance is dreadful. I have the 3070 Erazer Beast X25. 

26 REPLIES 26