cancel
Showing results for 
Search instead for 
Did you mean: 

Erazer X67098 - Second monitor not detected

SOLVED
4 REPLIES 4
Gil
Beginner
Message 1 of 5
350 Views
Message 1 of 5
350 Views

Erazer X67098 - Second monitor not detected

Hello!

 

I'm trying to connect a second monitor using the two HDMI ports of the Erazer X67098. I can connect one screen in any way I want (both HDMI ports work with both screens), but if they're both connected, the one that gets connected second simply never turns on, no matter which port I use first.

 

I checked the display driver for the GeForce GTX 1070 and everything is up-to-date. I rebooted trying several things, but so far nothing is solving the issue.

 

Any ideas what the problem could be?

 

Thank you for your help and have a nice Friday!

 

Kind regards,

1 ACCEPTED SOLUTION

Accepted Solutions
Gehringer
Retired
Message 4 of 5
341 Views
Message 4 of 5
341 Views

Hi @Gil ,

 

The unit is described as having only 1 HDMI on the rear enabled, which is most likely the one from the graphic card.

 

Can you please try to connect the second monitor using the Display Port?

Regards,

Gehringer

View solution in original post

4 REPLIES 4
Gehringer
Retired
Message 2 of 5
346 Views
Message 2 of 5
346 Views

Hi @Gil ,

 

can you please confirm the MSN number of your unit?

Also, is it in warranty?

Regards,

Gehringer

Gil
Beginner
Message 3 of 5
343 Views
Message 3 of 5
343 Views

Hi @Gehringer ,

 

Thank you for the feedback.

 

The MSN number is 10022833 and it's still under warranty until 15.11.2021.

 

Thank you for any help you can provide and I look forward to hearing from you.

 

Kind regards,

 

Gil

 

 

Gehringer
Retired
Message 4 of 5
342 Views
Message 4 of 5
342 Views

Hi @Gil ,

 

The unit is described as having only 1 HDMI on the rear enabled, which is most likely the one from the graphic card.

 

Can you please try to connect the second monitor using the Display Port?

Regards,

Gehringer

View solution in original post

Gil
Beginner
Message 5 of 5
339 Views
Message 5 of 5
339 Views

Hi @Gehringer ,

 

Ahhh that must be why! Unfortunately I don't have any cables at hand to test the Display Port, but I think we can leave it there. I'll give it a shot once I can find a display cable, then it should work as intended.

 

Thank you for your help!

 

Kind regards,

 

Gil

4 REPLIES 4