cancel
Showing results for 
Search instead for 
Did you mean: 

Display and USB not working.

10 REPLIES 10
Shal3R
Apprentice
Message 1 of 11
380 Views
Message 1 of 11
380 Views

Display and USB not working.

Hi. 

My Erazer x10 MD35036 just stoped working

It can be turned on but no signal to DP and us - Outputs not working.

 

Previously pc was crashing a lot by no-reason. Any ideas ? 

10 REPLIES 10
Fishtown
Superuser
Message 2 of 11
311 Views
Message 2 of 11
311 Views

Hi @Shal3R,

you asked for an update: https://community.medion.com/t5/ERAZER-Gaming/Erazer-x10-BIOS-update/m-p/119099

do you know this contribution and does it bring you further?

https://community.medion.com/t5/kb/en/ta-p/121863

bye Fishtown

--------------------------------------------------------------------------------------------------------------------------------------------------------
Alles was man lange genug, konsequent mit System durchführt, führt zwangsläufig zum Erfolg.
Shal3R
Apprentice
Message 3 of 11
305 Views
Message 3 of 11
305 Views

Thanks for answer.

How can i update bios if there is no signal from gpu and usb ports not working

 

PC turns on normaly but no signal from gpu un usb ports.

Fishtown
Superuser
Message 4 of 11
296 Views
Message 4 of 11
296 Views

Good Morning @Shal3R 

did you change anything in the software or hardware beforehand?

check all plugs whether they are correctly seated.

Check that the graphics card is inserted correctly.

If you take these out, do you still have an HDMI port on the motherboard that you could use?

bye Fishtown

--------------------------------------------------------------------------------------------------------------------------------------------------------
Alles was man lange genug, konsequent mit System durchführt, führt zwangsläufig zum Erfolg.
Shal3R
Apprentice
Message 5 of 11
292 Views
Message 5 of 11
292 Views

No modifications have been made it's in factory shape. It just simply stopped working. Pc turns on but no signal to gpu and usb but all fans spins.

But earlier i noticed that PSU did a terrable noise when playing some heavy games. And it really was very loud.

Could it be a dying PSU ?

 

the pc is only 3 mobths old

daddle
Superuser
Message 6 of 11
279 Views
Message 6 of 11
279 Views

@Shal3R 

 

You could measure if there is Power Output from ýour PSU on the 5 and 12 V line. If your fans spin (in the PSU as well), then it is not completely dead.

 

Try if your PC starts up with the F11 key pressed and holded down. If the PowerRecover menü appears, there is some boot troublewith your SSD.

Leave the PowerRecover menü by marking the Reboot tab, some PCs start  booting  Windows again.

 

And try a discharge of residual charge --> https://community.medion.com/t5/Videoclips-Tips-Tricks-Tutorials/Tips-Device-isn-t-responding/ta-p/9...

 

Cheers, daddle

Shal3R
Apprentice
Message 7 of 11
275 Views
Message 7 of 11
275 Views

PC just booted up with no problems after i left it unpluged for couple of hours. Could it be PSU ?

 

WILL try update bios

daddle
Superuser
Message 8 of 11
268 Views
Message 8 of 11
268 Views

@Shal3R 

 

Happy to have helped you.

But in the german part of the community, there is a long thread about freezes and irrational behaviour of the Erazer Engineer X10 serie. You have got an Erazer Engineer X10 ? 

Please post your MSN number. It's underneath on the bottom of the housing.

Is it MSN 10024042? Then yoiu gan make use of Bios V. 021.

 

Here you can Download the 021 Bios and th EC flash part . Read th e english flash instruction first.

Then unzip the bios_b560h6-em_v21.zip into a separate folder!

 

 First  you   flash  Part  1, the Bios. 

Then reboot,  and Part 2, the EC flashen.

After the EC flash, keep the PC off for at least 3 Minutes, then you can boot again.

 

Cheers, daddle

Shal3R
Apprentice
Message 9 of 11
266 Views
Message 9 of 11
266 Views

Yes i have MSN 10024042.

I will do an update today and i hope it will fix that issue. But i have new PSU aswell to replace in case there will be no signal again.

Shal3R
Apprentice
Message 10 of 11
256 Views
Message 10 of 11
256 Views

Im not able to update bios cuz when i start my pc it goes black shortly after it's booted up.  And no signal again.

10 REPLIES 10