cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to enter linux due to BIOS restriction - Medion Akoya P6687

Trainee
Message 1 of 2
291 Views
Message 1 of 2
291 Views

Unable to enter linux due to BIOS restriction - Medion Akoya P6687

Hi you all,

I'm starting this post because I'm currently unable to boot into any linux distro from my actual bios version.

I own a Medion P6687-MD60882 MSN 30023602 with a H2OS UEFI bios in version 203.

I've tried several usb sticks, several linux distributions, non of them worked. I tried them in a 3-year-old ASUS laptop and they're working flawlessly.

I've tried flashing the iso in several modes using rufus: MBR and GPT. Non of them worked either.

I've already disabled secureboot from the bios, which is really tricky to achieve (for no reason). I've enabled launch CSM.

I followed this little guide, which proposed to insert a file called bootia32.efi to /efi/boot. Didn't work either.

I'm really frustrated because I go on trying to solve this big issue and I'm unable.

 

There's a BIOS update for this specific model, which suposedly is 207 version. Once you open the installer you discover it's actually 209 version and you are really f*cked. The fans start spinning really loud, sound stops working on windows, performance decreases a lot... A total mess, but wou know what? Linux started working, which tells me that it's a bios issue and not my limited intelligence.

This faulty bios version is still up in the download section, so anyone can download it and spoil their laptops.

I had to return my first medion akoya p6687 for this reason, because it wasn't funtional, and now that I own a brand new one I'm again in the start point.

I've talked to the Spanish Medion Customer Service and it was a waste of time. No ofense intended, but they dind't provide me any solution. They didn't move away that faulty bios either even though they knew this issue was real.

 

So here I am trying to find any solution to this really big mess, because I'm between not being able to use linux and not being able to use windows.

I hope anyone from the Medion team can help me to solve it, or at least delete that faulty bios version from the download page.

 

Thank you all in advance,

Luis

1 REPLY 1
Highlighted
Community Manager
Message 2 of 2
214 Views
Message 2 of 2
214 Views

Re: Unable to enter linux due to BIOS restriction - Medion Akoya P6687

Thread closed due to inactivity.


MEDION. LÄUFT BEI MIR.
• Web: www.medion.de • Community: community.medion.com • Facebook: MEDIONDeutschland • Instagram: @medion.de


Bitte belohne hilfreiche Antworten mit Kudos und markiere die beste Antwort/Lösung mit Als Lösung akzeptieren.