Showing results for 
Search instead for 
Did you mean: 

Medion Erazer X6601 and Windows Home edition issue with VMware Workstation 10 and up

Message 1 of 2
Message 1 of 2

Medion Erazer X6601 and Windows Home edition issue with VMware Workstation 10 and up

Just received my Medion Erazer X6601 (Medion Erazer X6601-i7-256)

Expanded it with 8GB to 16GB and a 1TB SSD (Samsung EVO 850)


It has Windows 10 Home edition installed, which is good enough for  my purposes. I'm mostly interested in the quad core capabilities, RAM expandability and the secondary internal drive to host additional VMs on.


When I installed VMware workstation 12 (and later 10) I ran into some serious problems when starting VMs copied from my older system.

This was the message:

VMware Workstation unrecoverable error: (vcpu-0) vcpu-0:VMM DoubleFault



Some digging in the VMware forums showed possible issues with UEFI, Intel-VT, Trusted Execution, a non-64 bit host OS etc. The answers given were either not applicable or did not work for me.

So, this could be a problem in the VM migration. I verified by creating several 64 and 32 bit machines linux and Windows in Workstation. Same errors.


It's Home edition, so I checked if I hadn't been given the early release 32 bit version. It was the correct 64 bit version.

Checked the Intel CPU and internal settings, everything was on and worked properly.


Next step: look at the bottom, the BIOS.

This laptop contains an Aptio American Megatrends BIOS version. The number of features it supports is surprisingly limited versus what I'm used to (old BIOS and Server BIOS guy here)

One of the first thing I noticed was the 'security' tab.



Key management deals with importing all kinds of certs, so not interesting for the problems I was encountering. Also, it was off.

TPM configuration did spark my interest. Looking up what it does exactly:




So the tpm 2.0 module was enabled. I'm not too happy about the things a TPM ID can provide and the impact it can have on an OS level, so I figured I could just switch it off, see what happens.

Rebooted, W10 started up, logged in, started VMware Workstation, started my KALI linux version. Got an error the OS version was unsupported (Debian 64), so I changed it to recommended Ubuntu 64 bit. KALI started as usual, everything worked. Then my Windows XP Pro test machine. Started without a hitch.


Looks like the TPM module interferes with the VMware workstation execution of CPU functions. I don't think switching it off poses an extreme security hazard, unless you're in a high secure function and even then. Wonder why Medion switches it on in the first place, maybe some kind of default, whatever.


Hope this helps others in fixing this 'interesting' feature.










Message 2 of 2
Message 2 of 2

Re: Medion Erazer X6601 and Windows Home edition issue with VMware Workstation 10 and up

Hi @meznir


Thanks for the information on the issues you were having with VM's and TPM.

This will be very helpful for those running virtual machines.