abbrechen
Suchergebnisse werden angezeigt für 
Stattdessen suchen nach 
Meintest du 

E2293: Windows Upgrade schlägt fehlt - hosts Datei lässt sich nicht öffnen. Zusammenhang?

13 ANTWORTEN 13
Kong
Apprentice
Nachricht 1 von 14
251 Aufrufe
Nachricht 1 von 14
251 Aufrufe

E2293: Windows Upgrade schlägt fehlt - hosts Datei lässt sich nicht öffnen. Zusammenhang?

Hallo,

seit längerem habe ich das Problem, dass Windows Upgrades nach Version 1909 fehlschlagen. Im offenbar allerletzten Schritt, nach mehreren Neustarts im Zuge des Upgrades, erscheint sinngemäß die Meldung, dass der Rechner in den vorherigen Zustand zurückgesetzt wird. Dasselbe passiert bei Einsatz des Media Creation Tools. Fehlercode: 0x8007042b

Die monatlichen Updates laufen problemlos.

 

Heute ist mir ein zweites Problem aufgefallen, das möglicherweise dieselbe Ursache hat.

Die hosts Datei lässt sich nicht öffnen. Fehlermeldung des Editors: "Der externe unterstützende Anbieter wird nicht erkannt." Ob ich das mit Adminrechten oder ohne probiere, macht keinen Unterschied.

 

Was nun?

 

13 ANTWORTEN 13
daddle
Superuser
Nachricht 2 von 14
165 Aufrufe
Nachricht 2 von 14
165 Aufrufe

@Kong 

 

Meist ist das Problem, dass zu wenig freier Speicher auf der C-Partition vorhanden ist.

Wie gross, ist deine C-Partition und wieviel ist noch darauf frei?

 

Gruss, daddle

Kong
Apprentice
Nachricht 3 von 14
159 Aufrufe
Nachricht 3 von 14
159 Aufrufe

Es sind noch über 150 GB frei von 256. Das Gerät bootet von der gleich nach dem Kauf nachgerüsteten M.2 SSD, die MMC ist leer.

daddle
Superuser
Nachricht 4 von 14
149 Aufrufe
Nachricht 4 von 14
149 Aufrufe

@Kong 

 

Hallo Kong, hattest du die eMMC komplett leer gemacht und neu partitioniert?

Wenn da noch Reste (die Windows  Hilfspartitionen) oder die komplette Windows Installation drauf ist, kommt das Update beim Zwischenrebooten durcheinander und schreibt teilweise den zweiten oder dritten Anteil statt auf die neue M2 auf die eMMC. 

Nimm den MiniToolPartitionWizard, und schau dir die eMMC an und putz die leer, und lege einen neue komplett den Plattenspeicherplatz nutzende 60 gig grosse Partition an. Dann bist du sicher dass kein Bootloader mehr auf der eMMC sitzt, und das Upgrade durcheinander bringt.

 

Gruss, daddle

daddle
Superuser
Nachricht 5 von 14
144 Aufrufe
Nachricht 5 von 14
144 Aufrufe

@Kong 

 

Ergänzung:

Wenn das nicht der Fall ist, dann erstelle dir mit dem MediaCreationTool  einen Win 10 USB Installationsstick ("Für einen anderen PC erstellen"), min 8 GB, (auch dafür muss die eMMC leer sein) und mach dann damit offline das Update auf der neuen M2.

Vorher aber noch eine Datenträgerbereinigung (cleanmgr.exe) der C-Partition machen.

 

 Zu den Hosts

Ich hatte auch nach einem Klonvorgang dieselbe Fehlermeldung, und auch hier gepostet, aber es fand sich keine Lösung.

Ich habe dann ein Image, dass ich nach der Ersteinrichtung von der eMMC gezogen hatte (eine Recover Datei gibt es  ja nicht) auf die erweiternde M2 SSD aufgespielt. Anders bekam ich den Fehler nicht weg. Auch eine Neuinstallation über den USB Stick ginge, hatte ich zuerst probiert. Wichtig ist dass Du dir das Verzeichnis Drivers nach extern sicherst, denn die gibts nicht mehr im Download, soll alles Windows bereitstellenm, was es aber gerade bei den Convertibles nicht schafft (u.a Hinge Sensor services, Touchpad Disable )

 

 

 

Gruss, daddle

Kong
Apprentice
Nachricht 6 von 14
141 Aufrufe
Nachricht 6 von 14
141 Aufrufe

Hallo,

 

wie gesagt, die eMMC ist leer. Das Upgrade auf 1909 hatte seinerzeit ja auch funktioniert und das lief auch schon über die SSD.

Und das MCT hatte ich ja auch schon im Einsatz. Ich nehme an, dass das Problem mit der hosts damit zusammenhängt.

 

daddle
Superuser
Nachricht 7 von 14
138 Aufrufe
Nachricht 7 von 14
138 Aufrufe

@Kong 

 

Das host -Problem hattest Du aber von Anbeginn nach dem Klonen an. Aber egal, jetzt musst Du ein Image vom original Zustand  der eMMC aufspielen, oder falls Du den Computerschutz eingeschaltet hattest, mit der  Systemwiederherstellung (rstrui.exe) den Rechner auf ein möglichst frühes Datum zurückstellen lassen.

Sonst bleibt dir nur die Neuinstallation mit dem USB Stick. Da ist ja direkt die 20H2 drauf. Vergesse nicht vorher das Verzeichnis C:\ Drivers zu sichern.

 

Die Frage ob Du  die eMMC neu partitioniert hattest  hast du nicht beantwortet. Leer kann alles mögliche bedeuten.

 

Gruss, daddle

Kong
Apprentice
Nachricht 8 von 14
121 Aufrufe
Nachricht 8 von 14
121 Aufrufe

Ja, auf der eMMC befindet sich natürlich keine Startpartition mehr.

 

Könnte sich mal ein Moderator zum Problem mit der hosts äußern? Da Google fast keine Treffer dazu liefert und selbst auf Englisch kaum etwas dazu zu finden ist, scheint mir das doch ein Medion-Problem zu sein.

 

Danke.

daddle
Superuser
Nachricht 9 von 14
116 Aufrufe
Nachricht 9 von 14
116 Aufrufe

@Kong 


@Kong  schrieb:

Ja, auf der eMMC befindet sich natürlich keine Startpartition mehr.

Könnte sich mal ein Moderator zum Problem mit der hosts äußern? 


Was ist denn dann drauf? Es geht um die Efi, die zusätzlich MS undefinierte, die Windows Datenpartition und die Win RE Durchs neu Partitionieren über die gesamten Brutto 64 GB werdenauch die Startparameter im Bootbereich der Platte gelöscht. Erst dann ist die eMMC "richtig" leer. Wenn du den Tipp nicht befolgen willst ist deine Sache. Die direkte Frage ob du die eMMC neu partitioniert hattest, hast Du nicht beantwortet.

 

Und wie gesagt den Hosts -Fehler kriegte ich nicht weg. Ich denke  es hat was mit Berechtigungen zu tun, die in Win 10 Home nur, wenn überhaupt dafür nicht Win 10 Pro erforderlich wäre, mit intimen  Registry- und Windows Kenntnissen zu beseitigen wären.  

 

Und ich hatte auch ein erstaunliches Moderatoren Erlebnis: die Frage wurde nicht aufgegriffen.

Weiss aber wahrscheinlich auch keiner hier. 😉

 

Gruss, daddle

Kong
Apprentice
Nachricht 10 von 14
107 Aufrufe
Nachricht 10 von 14
107 Aufrufe

Meine Güte. Es ist eine primäre Partition drauf, nichts weiter. Ich benötige keine Anfängertipps. Dennoch Danke für Deine Mühe.

 

hosts??

13 ANTWORTEN 13