cancel
Showing results for 
Search instead for 
Did you mean: 

MEDION Mini-Geschirrspüler 37004 / Mini dishwasher not cleaning / problem

SOLVED
5 REPLIES 5
victoriam90
New Voice
Message 1 of 6
578 Views
Message 1 of 6
578 Views

MEDION Mini-Geschirrspüler 37004 / Mini dishwasher not cleaning / problem

Hello,

I have a mini dishwasher MD 37004 i bought in december 2020. It does not clean anymore. No water being heated and no "jets" of water on top, nor or on the bottom.
The timer goes down as normal, the water gets evacuated fine, but nothing happens other than that.

I emptied it fully, let it dry for 4 days, refilled it with water (1L) + salt and then the cycle water. No changes.

What could I try? There is no error being displayed.

Thanks in advance,

Victoria

1 ACCEPTED SOLUTION

Accepted Solutions
Gehringer
Retired
Message 4 of 6
547 Views
Message 4 of 6
547 Views

Hi @victoriam90 ,

 

in this case I would recommend you to get in touch with your local Medion technical team by phone/form.

 

There is probably a hardware fault.

 

Regards,

Gehringer

View solution in original post

5 REPLIES 5
Gehringer
Retired
Message 2 of 6
558 Views
Message 2 of 6
558 Views

Hi @victoriam90 , 

 

it may look like a basic troubleshooting, but have you checked the water installation?

Is it closed/blockid?


Does it follow the recommendations on the user manual, particularly in regards to its height in relation to the machine?

Is there any leaking?

Regards,
Gehringer

victoriam90
New Voice
Message 3 of 6
552 Views
Message 3 of 6
552 Views

Hi @Gehringer

 

Thanks for your reply!

 

I have the dishwasher setup as recommended on the user manuel. Please note i fill the water manually, but the dirty water comes out below my sink, attached with the metal ring with screws.

 

Exactly like so (dishwasher on kitchen top, tube going down to below the sink):

 

Screenshot_20210706-201329_Chrome.jpg

The water tube is not blocked, i also checked inside the machine below the filter and there is no blocage. Same on the top water filter. Also cleaned the rotating arm as indicated in the manual.

 

Edit: there is no leaking and has never been.

 

Kind Regards

Victoria

 

Gehringer
Retired
Message 4 of 6
548 Views
Message 4 of 6
548 Views

Hi @victoriam90 ,

 

in this case I would recommend you to get in touch with your local Medion technical team by phone/form.

 

There is probably a hardware fault.

 

Regards,

Gehringer

View solution in original post

victoriam90
New Voice
Message 5 of 6
543 Views
Message 5 of 6
543 Views

Thanks @Gehringer for following up, too bad it's not a fixable issue on my end. I'll contact the support 😊.

 

I'll accept your answer as a solution. Have a great day.

turbine
Newcomer
Message 6 of 6
152 Views
Message 6 of 6
152 Views

Hello, did you manage to fix this issue. I have the same problem.

5 REPLIES 5