cancel
Showing results for 
Search instead for 
Did you mean: 

AKOYA P2150 D no longer displays after adding/removing Graphics card

Newcomer
Message 1 of 5
283 Views
Message 1 of 5
283 Views

AKOYA P2150 D no longer displays after adding/removing Graphics card

Added a Gigabyte GTX 1050 without changing Bios settings. Monitor did not display anything through either onboard graphics or 1050. Removed 1050 and still not getting any display. Cables work as I've tested with another PC. There's no beeping. PC turns on and seems to function other than not displaying anything. Any suggestions?

 

4 REPLIES 4
Scientist
Message 2 of 5
269 Views
Message 2 of 5
269 Views

Re: AKOYA P2150 D no longer displays after adding/removing Graphics card

@Bobthebuilder

 

I try to help you - if you are lucky it works again

 

Search the net for BIOS reset!

 

 Perform a BIOS reset and test if the onboard card will work again.

 

Shut down your computer. Disconnect it from the network. Then press the power button again to to consume the fault current in the device. Remove the side cover of the PC. On the motherboard is a small button battery. Press the latch. Since there are manufacturer differences, wait about five minutes to replace the battery. After that, you can reassemble your computer.

 

 

Gruß Raymond


Contributor
Message 3 of 5
132 Views
Message 3 of 5
132 Views

Re: AKOYA P2150 D no longer displays after adding/removing Graphics card

I know this is an overdue reaction, but I do not agree with the above poster @Raymond that this might be solved with a BIOS update. The whole argument makes no sense because even if the BIOS wouldn't support your NIC (which isn't the job of the BIOS to begin with!) then it should be solved the moment you took the card out again!

 


@Bobthebuilder wrote:

Removed 1050 and still not getting any display. Cables work as I've tested with another PC. There's no beeping. PC turns on and seems to function other than not displaying anything. Any suggestions?

 


Do you have dual monitors on that system? What are the specs? What hardware do you have connected?

 

My suggestion: strip it down to basic needs only. One monitor, one keyboard and one mouse, then see what happens next.

 

Groetjes, Peter
Scientist
Message 4 of 5
112 Views
Message 4 of 5
112 Views

Re: AKOYA P2150 D no longer displays after adding/removing Graphics card

@ShelLuser 

 

what are you writing?

Not BIOS update but just reset, is something else!

If the problem does not exist with the Graphics Output Protocol (GOP) of the graphics card and the Compatibility Support Module (CSM) is disabled, only the reinitialization via the BIOS CMOS reset can be helpful, then the probable cause is the SMBIOS / UEFI BIOS of the motherboard is set incorrectly for the graphics adapter or something like that.

 

Kind regards

 

edit typo

 


Community Manager
Message 5 of 5
96 Views
Message 5 of 5
96 Views

Re: AKOYA P2150 D no longer displays after adding/removing Graphics card

Hello @Raymond ,

 

I agree with your approach, just added Step 2:

 

@Bobthebuilder :

 

1. Remove the additional GC.

2. Reset the PSU by removing the power cable, then press & hold the front power button for apprx. 30 seconds.

3. Check if PC is working now as it should.

4. If not, remove the CMOS battery for some minutes, then repeat Step 3.

5. Please report the results.

 

 

Cheers,

Luke


MEDION AG - A Lenovo Company • Web: www.medion.de • Community: community.medion.com • Facebook: www.facebook.com/MEDIONDeutschland


Bitte belohne hilfreiche Antworten mit Kudos und markiere die beste Antwort/Lösung mit Als Lösung akzeptieren.