abbrechen
Suchergebnisse werden angezeigt für 
Stattdessen suchen nach 
Meintest du 

Medion Akoya E3216 nach Clean Install geht autom. Tabletumschaltung nicht mehr

GELÖST
53 ANTWORTEN 53
meisteredu
New Voice
Nachricht 1 von 54
11.446 Aufrufe
Nachricht 1 von 54
11.446 Aufrufe

Medion Akoya E3216 nach Clean Install geht autom. Tabletumschaltung nicht mehr

Hallo,

 

habe mir für unterwegs das o.g. 2in1 Gerät gekauft und Windows 10 neu installiert. Nach der Installation habe ich alle anfallenden Updates von MS installiert, auch das Falls Creator Update. Was mir nun aufgefallen ist, seit der Neuinstallation funktioniert die automatische Umschaltung in den Tabletmodus beim Umklappen des Displays nicht mehr. Die Treiber habe ich von Medion runtergeladen und soweit alle installiert, aber leider funktioniert es nicht. Auch wird die Tastatur beim Umklappen nicht abgeschaltet. Der Haken in den Einstellungen, wie sich der Rechner beim Erkennen des Tablet-Modus verhalten soll, ist auch richtig gesetzt.

 

Habt Ihr ne Idee, wonach ich suchen kann?

 

Gruß

Johannes

53 ANTWORTEN 53
andi63
New Voice
Nachricht 41 von 54
324 Aufrufe
Nachricht 41 von 54
324 Aufrufe

Schönen Abend!

Ich hab jetzt auch noch versucht, das originale HingeAngleService.exe (Filedate 21.12.2016, aus dem ursprünglichen Driver Paket, das beim Kauf unter c:\Medion vorhanden war - ich hatte das vor der Neuinstallation gesichtert) im Admin Kontext nach c:\Windows\System32 zu kopieren und mit HingeAngleService -install zu installieren. Das Service installiert zwar, aber es erscheint auch eine Fehlermeldung zu SetEntriesInAcl 

--

Hinge angle service V1.0

SetEntriesInAcl failed(1332)
Service startup updated successfully.
Service description updated successfully.
Service failure actions updated successfully.

--

Und naja, Ihr habt es Euch sicher schon gedacht: Es funktioniert auch so nicht, es wird beim Umklappen weiter nicht in den Tabletmodus geschaltet.

 

Ich fürchte, wir müssen weiter auf die Antwort von @Andi und im Idealfall ein aktuelles Installationspaket für den Schaniersensor warten.

 

Liebe Grüße

Omibus
Apprentice
Nachricht 42 von 54
310 Aufrufe
Nachricht 42 von 54
310 Aufrufe

Bleibt uns wohl echt nix anderes übrig. 

Ich hoffe nur, dass Medion hier noch was tut. Sonst ist das aus meiner Sicht schon wieder ein Fall von geplanter Obsoleszenz. 

Andi
Master Moderator
Nachricht 43 von 54
179 Aufrufe
Nachricht 43 von 54
179 Aufrufe

Hallo zusammen.

 


@Omibus  schrieb:

Bei der Installation der Hideventfilter.inf bekomme ich jetzt eine Bestätigung nach der installation!

Was aber nach wie vor nicht geht ist die Installation des HingeAngleService. Es gibt keine Bestätigung nach installation der Inf Datei.

Dieser taucht auch nach Neustart nicht unter den Windows Diensten auf.


Es gibt jetzt ein neues Treiberpaket. Feedback erwünscht.

 

 

Gruß - Andi


MEDION. LÄUFT BEI MIR.
• Web: www.medion.de • Community: community.medion.com • Facebook: MEDIONDeutschland • Instagram: @medion.de


Bitte belohne hilfreiche Antworten mit Kudos und markiere die beste Antwort/Lösung mit Als Lösung akzeptieren.
daddle
Superuser
Nachricht 44 von 54
173 Aufrufe
Nachricht 44 von 54
173 Aufrufe

@Andi

 

Muss man,  so wie in den früheren Treiberpaketen, die SisIO.inf , nach Entpacken der zip,  z.B im Verzeichnis im Verzeichnis  C:\Medion\ _TP_Disable_  über Legacyhardware hinzufügen separat installieren? Und die andern, da keine setup oder cmd mehr dabei ist, jeweils über  inf install  installieren?

 

Gruss, daddle

Omibus
Apprentice
Nachricht 45 von 54
162 Aufrufe
Nachricht 45 von 54
162 Aufrufe

Hallo @Andi 

Ich habe jetzt wirklich lang rum geschustert, aber jetzt geht es!

 

Ich habe erst alles nach der Anleitung in Post 19 in diesem Thread versucht. Leider ohne Erfolg. 

Der Hingeangleservice lies sich nach wie vor nicht installieren.

 

Ich habe dann rausgefunden, dass Windows im Verzeichnis DriverStore unterhalb von System32 alle Treiberpakete ablegt, die jemals installiert wurden. Eine sauber Neuinstallation aller Treiber muss auch beinhalten, dass hier alle Vorversionen oder auch neuere Versionen, die aber inkompatibel sind, gelöscht werden.

Dazu würde es normalerweise eine Uninstall Routine benötigen. Und genau das fehlt in eurem Treiberpaket.

Bei der Installation der Treiber kam es scheinbar zu Problemen mit den Vorversionen. Windows unterbindet leider, dass man in diesem Verzeichnis einfach Dateien löscht.

Ich habe mir nun Abhilfe geschaffen und das Tool DriverStoreExplorer auf Github geladen:
https://github.com/lostindark/DriverStoreExplorer/releases/tag/v0.11.64

 

Und so hat es bei mir dann endlich zum Erfolg geführt:

Schritt 0: Optional einen Systemwiederherstellungspunkt erstellen. Bei mir hat alles geklappt. Aber ohne Gewähr.

Schritt 1: Alle Treiber nach der Anleitung in Post 19 entfernen/deinstallieren (Schritt 1-6)

Schritt 2: DriverStoreExplorer herunterladen und starten.
Schritt 3: Im DriverStoreExplorer sämtliche bestehende Treiber mit Namen

kxjhinge.inf,

hideventfilter.inf,

hingeangleservice.inf,

sisio.inf

LÖSCHEN. Falls die Meldung kommt die Treiber seien in Benutzung, löschen erzwingen Haken setzen und nochmals versuchen.
Wahrscheinlich hattet ihr einige der Einträge sogar mehrfach in unterschiedlichen Versionen vorliegen.
Bitte wirklich alle mit diesen Benennungen anticken und löschen erzwingen.

Schritt 4: Neustart

Schritt 5: Die Installation der Treiber wie in Post 19 beschrieben wieder durchführen (Schritt 7-11).

 

Wichtig: Automatische Treiberupdates in Windows Update deaktivieren! Sonst bügelt das euch die Treiber kaputt. Der Intel Hid Event-filter Treiber von Windows Update funktioniert zum Beispiel nicht mit den restlichen Treibern aus dem Paket. Wenn Windows Update diesen bereits ungewollt installiert hat, könnt ihr den alten Treiber wie folgt wiederherstellen und das automatische update dafür deaktivieren: klick.

Nach dem Neustart sollte der Laptop wieder wie gewohnt beim Umklappen in den Tablet Modus gehen und Tastatur und Touchpad deaktivieren.

@Andi Bitte gib der Technik nochmal weiter, dass es eine saubere uninstall Routine braucht. Meine Anleitung ist ohne Gewähr. Man kann sich mit sowas auch den PC lahmlegen, wenn man aus versehen den falschen Treiber antickt und deinstalliert. 
Ich bin mir fast sicher, dass es mit dieser Vorgehensweise auch mit den alten Treiberpaketen funktioniert hätte. Aber ich probiere das jetzt nicht aus, wo endlich alles läuft 😉

 

An alle anderen: Bitte gebt mir Rückmeldung, wenn das bei euch so auch funktionieren sollte. Nicht dass es ein zufälliger Einzelfall war.
Über Kudos freue ich mich natürlich!

andi63
New Voice
Nachricht 46 von 54
143 Aufrufe
Nachricht 46 von 54
143 Aufrufe

Vielen Dank an @Andi und @Omibus ! Es funktioniert mit Hilfe des neuen Treiberpaketes UND dem genialen Tipp von @Omibus zu dem DriverStoreExplorer!

Ich hatte anfangs versucht, die Treiber aus dem neuen Pakete "drüber" zu installieren und hatte keinen Erfolg - aber dafür das zusätzliche Problem, dass diverse Rechtsklick Menü's in Windows nach ein paar Sekunden automatisch wieder verschwanden, was das System dezent unverwendbar macht. Ich war schon fast am Weg zum Sondermüll, als die neue Empfehlung kam...

 

Folgende Anmerkungen:

- Ich hab das entpackte Driverpaket vorsichtshalber nicht im Download Folder belassen, sondern nach c:\Medion entpackt (da ich mir nicht sicher war, ob alle erforderlichen Komponenten im Driver Store landen oder nicht doch irgendwas bei jedem Start von dort geladen wird, wo man die Installationsdatei aufruft). Ist vermutlich sinnlos, tut aber auch nicht weh.

- Nach Deinstallationen und Bereinigung im DriverStoreExplorer waren die Kionix Treiber weg - aber nach einem Neustart im Geräte-Manager wieder da! Daher habe ich nach dem Neustart nochmal im Geräte-Manager Deinstalliert (inkl "Treiber entfernen"), noch ein zweites Mal im DriverStoreExplorer aufgeräumt und dann gleich drauf, ohne zweiten Neustart, die Installationen durchgeführt.

 

Danach nochmal neu gestartet und HURRA!

* Lagesensor funktioniert (das hatte eh immer funktioniert)

* Klappsensor funktioniert, automatische Umschaltung in den Tabletmodus funktioniert
* Touchpad und Tastatur sind im Klapp/Tabletmodus deaktiviert.

Bin begeistert! Vom Ergebnis, nicht vom Ablauf :-).

Ja, EIN Gesamtpaket mit einer Beschreibung, wie man nach einer Neuinstallation wieder zu einer funktionierenden Maschine kommt, wär wirklich eine Hilfe. Beim aktuellen Treiberpaket ist ja jetzt wieder KEIN BIOS Update dabei (oder ich habs nicht gefunden). Brauch ich auch nicht, weil ich das schon bei den letzten Versuchen installiert habe - aber was ist, wenn jemand unsere vorherigen Fehlversuche nicht gemacht hat? 

 

Aber natürlich ist MIR jetzt mal das Wichtigste - es funktioniert und dafür herzlichen Dank!

 

LG Andi

 

Omibus
Apprentice
Nachricht 47 von 54
138 Aufrufe
Nachricht 47 von 54
138 Aufrufe

@andi63 Das freut mich 🙂
Falls Windows Update dir den HID Event Filter doch updated, geh in den Gerätemanager und suche unter Eingabegeräte (Human Interface Devices) den Intel HID Event Filter. Da mit rechtsklick drauf und "Vorgängerversion wiederherstellen" klicken. Dann gibst du als Grund an, dass deine Hardware nicht mit der neuen Version kompatibel ist. Dann macht Windows Update hier auch kein Update mehr und alles bleibt auch so wie es soll.

andi63
New Voice
Nachricht 48 von 54
125 Aufrufe
Nachricht 48 von 54
125 Aufrufe

Ja, und genauso wars dann auch :-). Habe aus Neugier direkt nachdem ich den Post geschrieben hatte ein Windows Update gemacht, das hat mir auch gleich ungefragt eins für den "Intel HID Event Filter" verpasst - und danach war Schluss mit lustig. Jetzt funktionierte weder der Lage- noch der Klappsensor, keine Drehung, keine Umschaltung.

Deshalb mach ich das mit dem Windows Update immer gleich nach solchen Aktionen, in ein paar Tagen oder Wochen sucht man dann länger nach der Ursache...

Die Lösung von @Omibus angewandt (im Gerätemanager auf die Vorversion rückgestiegen mit Angabe "neuer Treiber geht nicht" (oder so) und es werkt wieder wie zuvor = es dreht und klappt wie's soll.

 

Nochmal danke, schönen Abend

Andi

  

Andi
Master Moderator
Nachricht 49 von 54
99 Aufrufe
Nachricht 49 von 54
99 Aufrufe

Hallo @daddle.

 


@daddle  schrieb:

Muss man,  so wie in den früheren Treiberpaketen, die SisIO.inf , nach Entpacken der zip,  z.B im Verzeichnis im Verzeichnis  C:\Medion\ _TP_Disable_  über Legacyhardware hinzufügen separat installieren? Und die andern, da keine setup oder cmd mehr dabei ist, jeweils über  inf install  installieren?


Ich habe mich hierzu einmal erkundigt. Sis.IO so wie bisher über Legacyhardware hinzufügen und die anderen beiden Treiber über die inf installieren. Ganz genau.

 

 

Gruß - Andi


MEDION. LÄUFT BEI MIR.
• Web: www.medion.de • Community: community.medion.com • Facebook: MEDIONDeutschland • Instagram: @medion.de


Bitte belohne hilfreiche Antworten mit Kudos und markiere die beste Antwort/Lösung mit Als Lösung akzeptieren.
daddle
Superuser
Nachricht 50 von 54
78 Aufrufe
Nachricht 50 von 54
78 Aufrufe

@Andi 

 

Vorab noch eine Rückfrage: lädt man das Treiberpaket herunter, bekommt man ein Treiberpaket für das E322x

--> e322x_switch_driver_update_02_21.zip. Der Thread geht über das E3216. 

 

Da ich das E3221 habe, und das E3216 hatte, aber noch die Treibersammlung dazu besitze, zeigt sich im Vergleich das für das E3221 die SisIO.inf über Legacyhardware hinzufügen in der cmd steht.

 

Im Gegensatz dazu ist es für die E3216 eine --> install.bat im Verzeichnis C:\Medion_3216\ 14_Touchpad_disable\ : 

C:\...\ 14_Touchpad_disable \ TPMonitor_Setup_v1.0.7.exe

C:\...\ 14_Touchpad_disable \ install.bat

 

Gilt jetzt die Dateien in dem Treiberpaket  e322x_switch_driver_update_02_21.zip für beide Convertibeles, dem E3216 und dem E3221? 

Wäre ja gut möglich da beide Emdoor Barebones haben

 

Habe versucht das vorher per  PN abzuklären, aber schon beim Abschickungsversuch der ersten PN kommt die rot bebalkte Mitteilung, man würde das Limit überschreiten? 

"Du hast die für das Senden privater Nachrichten festgelegte Grenze erreicht. Versuche es später erneut."

 

Für Diejenigen, die über die hdwwiz.exe nachinstallieren müssen: Ich fürchte das können nur die Wenigsten so aus dem Handgelenk heraus. Im originalem Treiberpaket E3221 ist zur Installation der SisIO.inf  ein Textabschnitt in der cmd, in dem das beschrieben wird: (Wenn es noch für manche User einer Übersetzung bedarf, reiche ich die gerne nach):

 

 

Echo.
Echo.To install the last driver, please follow these steps:
Echo.======================================================
Echo. * In the Add Hardware Wizard click Next
Echo. * Select the 2nd option:
Echo.     Install the hardware that I manually select from a list ^(Advanced^)
Echo. * Search for 'System devices', then click Next
Echo. * Click 'Have disk', click 'Browse', point to the folder 'TP_Disable'
Echo. * Select 'SisIO.inf', click 'Open', click 'Next', again click 'Next'
Echo. * Click 'Finish'
Echo.
Start "" /Wait Hdwwiz.exe

    Goto Done

 

 

Mit freundlichem Gruss, daddle

53 ANTWORTEN 53