abbrechen
Suchergebnisse werden angezeigt für 
Stattdessen suchen nach 
Meintest du 

ERAZER Engineer X10 (MD 34767) NvMe M.2 im zweiten Slot wird nicht erkannt

GELÖST
17 ANTWORTEN 17
CY-57
New Voice
Nachricht 1 von 18
972 Aufrufe
Nachricht 1 von 18
972 Aufrufe

ERAZER Engineer X10 (MD 34767) NvMe M.2 im zweiten Slot wird nicht erkannt

Hallo,

in der Hoffnung, das System um weitere 2GB erweitern zu können, habe ich eine NVMe M.2 SSD einbauen wollen. Leider wird diese weder im UEFI noch in der Windows Datenträgerverwaltung erkannt. Im UEFI ist in den SATA Einstellungen für die Ports 1 bis 5 nur "Empty" angegeben, das Systemlaufwerk finde ich dort gar nicht (wo ist SATA0?). Nur in der Boot Configuration steht an 4. Stelle "UEFI Hard Disk: Windows Boot Manager" mit der korrekten Bezeichnung der Intel NVMe SSD.

Die MSN meines Rechners ist: 1002 3601.

Unterstützt das Mainboard eine weitere NVMe SSD auf dem 2. Steckplatz überhaupt? Und wenn ja, was läuft schief bei der Erkennung?

Für Lösungsvorschläge wäre ich sehr dankbar!

Grüße

CY-57

 

 

 

2 AKZEPTIERTE LÖSUNGEN

Akzeptierte Lösungen
Fishtown
Superuser
Nachricht 9 von 18
542 Aufrufe
Nachricht 9 von 18
542 Aufrufe

Moin @CY-57 und willkommen

Du hast ein B460H6-EM Board

Hier kannst du sehen welche M.2 Karten du einbauen kannst:

https://community.medion.com/t5/FAQs/FAQ-Spezifikationen-Mainboard-quot-ECS-B460H6-EM-quot/ta-p/9715...

Moin @Farron,  Datenbank geht wieder bei mir nach Vergabe eines neuen Passworts.

Tschüss Fishtown

--------------------------------------------------------------------------------------------------------------------------------------------------------
Alles was man lange genug, konsequent mit System durchführt, führt zwangsläufig zum Erfolg.

Lösung in ursprünglichem Beitrag anzeigen

daddle
Superuser
Nachricht 16 von 18
790 Aufrufe
Nachricht 16 von 18
790 Aufrufe

@Farron 


@Farron  schrieb:

SATA Anschlüsse haben normalerweise 2 Stege und entsprechende SATA M.2 SSD haben demnach auch zwei Schlitze (B+M Key) 

Das ist so nicht ganz richtig. SATA Platten haben im allgemeinen 2 KEYs B+ M, damit sie in beide verschiedenen Ports je nach Vorhandensein mechanisch passen; sagt aber nichts über die Anschlussart aus.

Auch nicht dass zwingend zwei Stege im Edge-Connector vorhanden sein müssen. Das SATA Protokoll kann sowohl über die  B-Id wie auch über die  M-Id eingebunden werden. Die  Geschwindigkeít  der Ports ist bei beiden gleich.

Nur bei PCIe ist das anders. der reguläre PCIe Key ist der M-Key (mit dem PCIe-Protokoll) und liefert PCIe x 4; während der PCIe Anschluss an die B-Id ebenfalls möglich ist, aber nur PCIe x 2 liefert. Dahe r werden PCIe M2 SSDs fast nur in der Bauart mit einem Key M verkauft.

 

Der Port oder Slot heisst auch nicht B- oder  M-Port, sondern Port oder Slot für einen B (oder M) -Key Edge Connector; ein kleiner aber feiner Unterschied,

 

Da also beide Anschlussarten für beide Plattentypen möglich sind, baut man sozusagen (um es planerisch und produktonstechnisch einfacher zu machen) überwiegend Ports ein mit der Lücke bei M (re), und nur einem Steg auch bei M. Dann passt eine SATA M2 auf jden Fall.

Da die SATA Platten zwei Key-Ids hat,, also auch zwei Aussparungen hat, würde sie aber auch in einen Port mit zwei Stegen passen,  auch in einen Port für den M-Key wie oben gesagt, also mit nur einer Lücke, und natürlich nur einem Steg, Trotzdem kann dort eine SATA M 2 andocken, da die Protokoll Anbindung ja ungestört trotzdem erfolgen kann.

 

Um es einfacher zu machen, baut man oft nur noch den einen Port Typ für den  M-Key Edge-Connector  ein (inc.Steg) (wie bei @CY-57 ), trotzdem kann eine SATA M2 dort eingebaut werden, und das SATA Protokoll an die B-Id oder die M-Id angekoppelt sein. Denn die Keys sind ja nur mechanische Hllfen, die  Lücken M+B-Key bleiben ja soiweso vorhanden, egal ob der empfangende Slot   B oder M oder beide Keys (Lücken und Stege) anbietet. 

 

Die Kontakte die dann am M-Key fehlen, braucht eine SATA Platte nicht, da das SATA  Protokoll (sozusagen) trotz der fehlenden Kontakte  12-19 und 59-66 weiterhin übermittelt wird.  Ausserdem könnte das SATA-Protokoll auch über die M-Key Id selber angebunden sein. (neben den Kontaktaussparungen 59-66).

Aber die numerische Zuordnung ist nicht zwingend, (s.o.) es ist nur ein logische Zuordnung

Bei PCIe nimmt man nur die KEY-Id M, da diese PCIe x4, also die doppelte Geschwindigkeit liefert. Es hängt also davon ab welches Protokoll an welche Key-Id angebunden ist.

 

Da der Port beim B460 nur eine Lücke rechts hat (und nur 1 Steg), passt mechanisch die PCIe hinein. Daher konnte @CY-57  die Platte sauber einbauen (unterbringen!). aber das passende PCIe Protokoll fehlte.

Alles etwas verwirrend, aber es ist wenn man so will, ein halb offenes System mit min. 7 Variablen, die sich fast beliebig nach Laune (bzw Kalkulation des Herstellers) konfigurieren lassen.

 

 


@Farron  schrieb:

 

...wenn du deine zweite SSD problemlos in den Steckplatz unterbringen konntest, sollte dieser auch für NVMe geeignet sein.

 

@daddle  schrieb:

Farrons Äusserung kann man so nicht pauschal übernehmen. Eine SATA M2 kann man problemlos auch in einen Slot der eigentlich für eine PCIe M2 gedacht ist, unterbringen.

 

@Farron schrieb

Ja genau aber wir reden doch hier von einer NVMe Samsung 970 EVO und die kann man nunmal nicht problemlos in einem SATA Anschluss unterbringen


Und ja eben doch, die PCIe M2 lässt sich in einem für SATA konfigurierten Port  unterbringen, obwohl dieser wie oben dargelegt keinen B-Key haben muss.  Dass sie mechanisch hinein passt heisst aber nicht daraus liesse sich schliessen, es muss zwingend ein PCÌe M2  Anschluss sein, wie du eingangs behauptet hattest.

 

Macht das was? Nein. Die anderen Kontakte die für eine B-Key M2 das SATA Protokoll anbinden, sind ja vorhanden. Sonst könnte eine SATA M2 mit 2 Key-Aussparungen ja auch nie funktionieren.

Und Key bezieht sich auf die mechanischen Aussparungen im Connector der M2 Platte, nicht zwingend auf die logische Anbindung im Port.. Was stört es eine SATA M2 mit B+M Key, ob unten nur ein Steg oder zwei vorhanden sind. Die Lücken haben sie sowieso, und passen damit in jeden M2 Slot.

 

Aber du velinkst selber den Wikipedia-Artikel, dann müsstest Du das nach der Lektüre doch wissen? 😀

 

@CY-57 

 

Du hast vollkommen recht mit deinen Äusserungen und ich sehe man kann es doch verstehen,  a.) was  ich schrieb und  b.) im Wiki Artikel klar dargelegt wird. Es ist nur sehr komplex und vielschichtig, da logische und mechanische Anbindung nicht Hand in Hand gehen müssen.

 

Übrigens ist das Bild des MB nicht von mir gemacht!  🙂  Das Board ist i.O.; bei meiner Version kannich  nur leider keine Bios-Emulation aufrufen.

 

Dann viel Erfolg und anschliessendem Spass nach Einbau der SATA M2 SSD.

 

Gruss, daddle

Lösung in ursprünglichem Beitrag anzeigen

17 ANTWORTEN 17
Farron
Superuser
Nachricht 2 von 18
586 Aufrufe
Nachricht 2 von 18
586 Aufrufe

Hallo @CY-57 

 

So wie ich es aus der Beschreibung zum PC heraus lese, hast du bereits eine NVMe mit 1 GB verbaut,

Momentan ist leider die Datenbank offline aber wenn du deine zweite SSD problemlos in den Steckplatz unterbringen konntest, sollte dieser auch für NVMe geeignet sein.

Die SSD sollte weiterhin in der Datenträgerverwaltung sichtbar sein, eventuell mal ein bisschen scrollen. Hier musst du der SSD noch einen Laufwerksbuchstaben zuweisen, dann sollte sie auch erkannt werden.

 

Etwas verwirrend ist deine Aussage, dass du die Boot SSD nicht in den SATA Einstellungen des BIOS findest. Was soll sie auch da ? Es ist eine NVMe (PCI) SSD und keine SATA.


Gruß Farron
-------------------------------------------------------------
Irgendwas ist immer
ERAZER® x17805, MD 61854, MSN 30029435
CY-57
New Voice
Nachricht 3 von 18
581 Aufrufe
Nachricht 3 von 18
581 Aufrufe

Hallo Farron,

danke für deine schnelle Antwort. 

Ist schon länger her, dass ich an Rechnern konfiguriert habe. Ich würde mich freuen, wenn du noch einmal in der Datenbank nachsehen könntest. In der Zwischenzeit versuche ich, die SSD noch einmal einzubauen, vielleicht habe ich sie ja nicht richtig eingesteckt. Eine 1TB NVMe ist als Systemlaufwerk schon drin.

Gibt es im Bios keine Konfigurationsseite, in denen die SSDs Konfiguriert oder wenigstens erwähnt werden müssen? Die hatte ich nirgends gefunden.

 

Grüße

CY-57

CY-57
New Voice
Nachricht 4 von 18
572 Aufrufe
Nachricht 4 von 18
572 Aufrufe

 ...hier noch ein Nachtrag:

Nochmaliges, bewusst sauberes Einbauen hat keine Änderung erbracht.

Im Bios unter der SATA-Seite ist ein Abschnitt "Intel Rapid Storage Technology" aufgeführt, wo unter "Non-RAID Physical Disks" nur die 1TB System SSD aufgeführt ist (interessanterweise als PCIe 1.0, Intel SSD), sonst aber keine.

Farron
Superuser
Nachricht 5 von 18
571 Aufrufe
Nachricht 5 von 18
571 Aufrufe

Hallo @CY-57 

 

Da wie gesagt, die DB momentan nicht benutzbar ist kann ich dort nicht nach sehen.

Ich weiß also nicht welches MB in deinem Rechner steckt.

Im BIOS müsste die Boot SSD wenigstens gelistet sein, wie z.B. im Bild. Kommt aber auch auf das BIOS an wo sie zu sehen ist.

 

NVME_Bios.jpg

 

EDIT: Wie ist denn die Bezeichnung deiner neuen SSD ?


Gruß Farron
-------------------------------------------------------------
Irgendwas ist immer
ERAZER® x17805, MD 61854, MSN 30029435
CY-57
New Voice
Nachricht 6 von 18
562 Aufrufe
Nachricht 6 von 18
562 Aufrufe

Hallo Farron,

es ist eine Samsung 970 EVO Plus 2 TB PCIe 3.0

Hier noch das Bild aus dem Bios:

20211006_171113709_iOS.jpg

 

Grüße

CY-57

Farron
Superuser
Nachricht 7 von 18
558 Aufrufe
Nachricht 7 von 18
558 Aufrufe

@CY-57 

 

Dein Bild kann man frühestens morgen sehen, es muss noch freigegeben werden.

Aber ich sehe schon, ohne Bezeichnung des MB kommen wir nicht weiter, den Engineer x10 gibt es in vielfältigen Ausführungen.

 

EDIT: Konntest du die neue SSD mit der Schraube befestigen ?


Gruß Farron
-------------------------------------------------------------
Irgendwas ist immer
ERAZER® x17805, MD 61854, MSN 30029435
CY-57
New Voice
Nachricht 8 von 18
550 Aufrufe
Nachricht 8 von 18
550 Aufrufe

Hallo Farron,

...ja, allerdings musste ich mir erst die Verlängerung (Abstandshalter) und eine Schraube bestellen. Drauf war keine (2 Schraublöcher für verscheiden lange Speicher waren vorgesehen), vielleicht waren die in einem Beutel bei der Auslieferung dabei und wir konnten zunächst nichts damit anfangen - oder es gab keine... jetzt gibt es sechs im Beutel 😉.

Aber es passt sauber wie im ersten Slot mit der System-SSD.

 

Grüße

CY-57

Fishtown
Superuser
Nachricht 9 von 18
543 Aufrufe
Nachricht 9 von 18
543 Aufrufe

Moin @CY-57 und willkommen

Du hast ein B460H6-EM Board

Hier kannst du sehen welche M.2 Karten du einbauen kannst:

https://community.medion.com/t5/FAQs/FAQ-Spezifikationen-Mainboard-quot-ECS-B460H6-EM-quot/ta-p/9715...

Moin @Farron,  Datenbank geht wieder bei mir nach Vergabe eines neuen Passworts.

Tschüss Fishtown

--------------------------------------------------------------------------------------------------------------------------------------------------------
Alles was man lange genug, konsequent mit System durchführt, führt zwangsläufig zum Erfolg.

Lösung in ursprünglichem Beitrag anzeigen

daddle
Superuser
Nachricht 10 von 18
534 Aufrufe
Nachricht 10 von 18
534 Aufrufe

@CY-57 

 

Hallo CY-57

 

@Farron  schrieb:

Im BIOS müsste die Boot SSD wenigstens gelistet sein, wie z.B. im Bild. Kommt aber auch auf das BIOS an wo sie zu sehen ist


Die Bootplatte hat @CY-57  ja gesehen, sogar zweimal. Einmal unter "intel RapidStorage Technology --> Non-Raid Physical Disks

und zum zweiten auf der Bootseite mit dem WindowsBootManager markiert.



@Farron  schrieb:

 

- ... aber wenn du deine zweite SSD problemlos in den Steckplatz unterbringen konntest, sollte dieser auch für NVMe geeignet sein.

Farrons Äusserung kann man so nicht pauschal übernehmen. Eine SATA M2 kann man problemlos auch in einen Slot der eigentlich für eine PCIe M2 gedacht ist, unterbringen.

 

Da die SATA M2 meist 2 Keys hat, den B und den M-Key (Kerben in der Platinenanschlussleiste), passen sie mechanisch auch in einen Slot für die PCIe M2 die nur einen B Key hat.

 

Die Frage ist welches Protokolll ist für den zweiten M2 Port implementiert, und an welchen Key angebunden.

Allerdings hat Fishtown in seinem Post für das MB B560 beschrieben, dass der zweite M2 Port auch für eine PCIe gedacht ist.

 

Wenn deine PCIe M2 nicht erkannt wird, kann es mehrere Ursachen haben:

 Die Platte müsste erst in der Datenträgerverwaltung initialisiert werden, bevor sie partitioniert unf formatiert werden kann.

Dann sollte sie aber im Bios erkannt worden sein, und zwar im  gleichen Menüpunkt,  wo auch deine 1. PCIe unter "Non-Raid Physical Disk" gelistet wird.  Aber diese nicht auf der Bootseite, da  kein (bootbares) Betriebssystem mit einem WindowsBootManager vorhanden ist.. 

Im Bios unter SATA Configuration  --> "Intel Rapid Storage Technology" --> "Non-RAID Physical Disks" sollte auch 

 die zweite PCIe erscheinen.

 

Tut sie das nicht, könnte es sein dass Du die Platte seitlich verdreht eingebaut hast. Das geht da die Kerbe bei einer PCIe mit M-Key 5 Kontakte vom seitlichen Rand liegt. Für den typischen SATA Key, ein B-Key, sind dagegen seitlich zum Rand hin nur 6 Kontakte vorhanden.. Da fällt es relativ leicht, die Platte seitlich verdreht gegen einen leichten Widerstand einzusetzen.

Die Platten Chips müssen bei einseitiger Bestückung nach oben zeigen. 

 

Hat also dein zweiter M2 Port links (für B-Key) eine Aussparung und im Boidenbereich eine etwas hochstehende Leiste, wäre der Port ein SATA-Port für eine SATA M2  das ist fast Standard (es gibt aber seltenere Ausnahmen)

 

Siehst Du aber im Port rechts  5 Kontakte vom Rand weg eine Lücke, ist es mit ziemlicher Sicherheit ein PCIe bestückter Port.

Die Kontaktleiste deiner Evo 970 richtig gehalten sollte so aussehen:

PCIe SSD mit M-KeyPCIe SSD mit M-Key

Diese Seite muss beim Einstecken oben sein, so dass der Key (die Lücke) recht sliegt.

Und so schematisch, auch  mit dem Port oben, und der Kontaktleiste unten abgebildet:

M-Key +Port.PNG

 

 Wird sie dann immer noch nicht gefunden, kann sie defekt sein. Oder der Port ist doch mit einem  SATA  Protokoll belegt. (das M2 SATA Protokoll kann auch am M-Key statt am Standard B-Key angebunden sein); 

 

Dann müsste eine SATA M2  aber unter den SATA-Anschlüssen zu finden sein. Da Du aber eine Evo als PCIe hast, könnte sie bei Anbindung des Ports mit dem SATA-Protokoll natürlich auch nicht angezeigt werden.

 

Gruss, daddle

 

Edit: Sehe gerade  @Fishtowns Post, dass Du ein B460 H6-EM Mainboard hast. (Ich war zwischendurch mal weg).  Dann musst Du die Evo zurückschicken, denn de zweite M2 ist definitiv eine M2 SATA. Ich habe das Mainboard selber.

Hier ist ein Bild vom Board:

B460H6-EMt.PNG

 

Da hätte ich mir den langen Vorlauf ersparen können. Aber bildet  ja auch. 😊

 

 

 

17 ANTWORTEN 17