abbrechen
Suchergebnisse werden angezeigt für 
Stattdessen suchen nach 
Meintest du 

Linux-Installation Fedora 24 XFCE x86_64 auf Akoya P5320 E im UEFI-Modus mit Secure-Boot

Nachricht 1 von 12
1.280 Aufrufe
Nachricht 1 von 12
1.280 Aufrufe

Linux-Installation Fedora 24 XFCE x86_64 auf Akoya P5320 E im UEFI-Modus mit Secure-Boot

Wollte das auch schon seit einiger Zeit auf dem Rechner ausprobieren, und habe das jetzt gewagt, und soeben erfolgreich durchgeführt.

 

Der Akoya P5320 E basiert auf dem H110H4-CM2 Mainboard, i5-6400 CPU, 128GB M.2 SATA SSD, 2TB 3,5" HDD, Nvidia GF 750Ti, 8GB DDR3L SDRAM.

Im UEFI / BIOS Einstellungen bleiben unverändert wie für Win 10 mit Secure-Boot.

 

Das Image F24-x86_64-XFCE-20161108.iso der Installations-DVD bekommt man ua. dort:

http://dl.fedoraproject.org/pub/alt/live-respins/

Diese kann man unter Windows10 als "CD-Image brennen" in einem CD/DVD Brennprogramm, müsste auch mit dem von Cyberlink funktionieren, ansonsten CDBurnerXP verwenden. http://cdburnerxp.se/de/home

 

Man startet den Rechner also neu, mit gedrückter "F8" Taste, und lässt im Bootmenü von CD/DVD booten.

 

Im gestarteten Fedora Live-Linux geht man als erstes mit dem Mauszeiger auf die Taskleiste, mit rechter Maustaste auswählen "/panel/add new item/keyboard layouts"

Im neu hinzugefügten Konfigurationsfeld nun also layout add/"german, eliminate dead keys" ausführen, und auswählen, und das vorhandene "english(US)" ggf löschen.

Somit ist im Live-Linux die deutsche Tastatur als Systemstandard eingestellt, und man kann das Betriebssystem ausprobieren und konfigurieren.

 

Um die Installation vorzubereiten benötigt man eine freie Partition für Linux, welche mit ext4 formatiert wird.

Hierzu öffnet man ein Terminal mit dem Icon von der Menüleiste unten, und gibt ein (nach $)

$ sudo su

um Administratorrechte zu erlangen.

Danach startet man gparted

# gparted

und wählt dort als Gerät /dev/sda 2TB aus. Jetzt wird die erste Partition sda1 ausgewählt, und verkleinert, sodass dahinter 80000 MB frei bleiben. Mit dem neuen freien Platz erstellt man gleich eine ext4 Partition linux/fedora (name/label), die nun als sda3 geführt wird.

 

Nun öffnet man am Desktop über das Icon "Install to hard drive" das Installationsprogramm.

Hier zuerst wieder Deutsch/"Deutsch eliminate dead keys" auswählen als Tastaturlayout.

Dann als Installationsziel beide Festplatten auswählen, und Booten von 2.Festplatte sdb  (die SSD) festlegen.

Partitionierung auf "manuell" einstellen,

und unter /unbekannt/ sda3 ext4 (die zuvor erstellte Partition) auswählen und als Einhängepunkt "/" (root) festlegen, sowie neu formatieren auswählen. Einstellungen aktualisieren wählen.

Dann unter  sdb efi auswählen und als Einhängepunkt "/boot/efi" festlegen. Einstellungen aktualisieren wählen.

Zweimal Fertig anklicken, und die Installation starten.

Passwörter für Administrator und für Benutzer festlegen.

Neustarten mit gedrückter F8-Taste, die DVD herausnehmen, und im BootMenü Linux wählen.

 

Dann auf dem neu gestarteten Linux am Desktop ein Terminal öffnen, und sich als Administrator anmelden.

$ su -

Wir erstellen nun ein Swapfile mit 2GB, damit uns etwas virtueller Speicherplatz zur Verfügung steht.

# cd /

# dd if=/dev/zero bs=1K count=2048K of=swapfile

# chmod 0600 swapfile

# mkswap swapfile

# nano /etc/fstab  

dort diese Zeile am Ende einfügen, und mit CRTL-O speichern

/swapfile none swap defaults

# swapon -a

Nun sollte der Swapspeicher mit 2GB eingebunden sein. Man kann ihn auch vergrößern, indem man mehrere solcher Dateien anlegt, oder die og. Datei /swapfile  selbst vergrößert.

 

Dann sollte man noch mit nano /etc/default/grub editieren, und in die GRUB_CMDLINE_LINUX "resume=/swapfile" hinzufügen. Abschließend die Konfiguration aktualisieren:

# grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

siehe: http://fedoraproject.org/wiki/Common_F24_bugs

 

Man sollte die Eingabesprache auf Deutsch umstellen.

Zu finden unter Menüleiste/Applications/Administration/Language.

 

Das war es eigentlich, im Grunde sollte es jetzt laufen.

Man kann im Terminal gleich die installierte Software und Betriebssystem aktualisieren lassen, mit

# dnf update

Man kann in XFCE die Menüleisten intelligent ausblenden, zB. die untere, wenn sie von einem Fenster verdeckt wird. Dazu mit rechter Maustaste auf die Leiste klicken, und Leisteneinstellungen auswählen.

Dann "Leiste automatisch verbergen: intelligent" auswählen.

 

Vielleicht hat ja jemand Verbesserungsvorschläge, dann bitte posten.

 

 

wünsche gutes gelingen,

MfG. Kill_Bill

11 ANTWORTEN
Nachricht 2 von 12
1.251 Aufrufe
Nachricht 2 von 12
1.251 Aufrufe

Re: Linux-Installation Fedora 24 XFCE x86_64 auf Akoya P5320 E im UEFI-Modus mit Secure-Boot

moin @Kill_Bill

schigg‘!

das sollte ja auch für andere rechner gelten können ;-)

2 gig swap finde ich zwar a‘ bissl‘ “überdimensioniert“ - aber jeder wie mag!

da ich unter win10 viele proggies‘ eher seltener brauche (masterc6&co) – und somit mein PowerNoteBook (fremdfabrikat mit 18,4" und am 27“ externem monitor)) gar nicht mehr ‘anschmeissen‘ brauche – habe ich mich jedoch direkt für einen ‘kleinen‘ linuxrechner entschieden – für das ‘normale‘ alltags_online_verhalten reichts digge‘ - sogar für mehr ;-)

mit maus&tastatur per usb und am 27"-monitor (FHD) - uuund spart strom ohne ende :-)

ODROID-C2

danke für die info - gibt alternativen zu win uuund mehr sicherheit :-)

grüssinx

Nachricht 3 von 12
1.242 Aufrufe
Nachricht 3 von 12
1.242 Aufrufe

Re: Linux-Installation Fedora 24 XFCE x86_64 auf Akoya P5320 E im UEFI-Modus mit Secure-Boot

Hallo McB, hallo Kill_Bill,

 

Zitat: gibt alternativen zu win uuund mehr sicherheit :-)

 

Na ja, das ist natürlich sehr von der persönlich notwendigen Software abhängig.

Ich hatte aufgrund des alten Tipps von Kill_Bill Fedora24 mal als Live System auf dem P5320 E getestet. Das war im Rahmen von Linux Notfall Medien, die bislang wegen der dahinter steckenden alten Versionen nicht gelaufen sind bzw. einiger Tricks bedurften. Mit Fedora hat das Live System sofort geklappt, sodass man wahrscheinlich noch warten muss, bis fertige Medien problemlos auf diesem PC laufen.

 

An der VirtualBox mit WIN 10 und Gast zunächst Fedora (keine KomandozeilenSmiley (zwinkernd)), später Linux Mint, bin ich noch dran, ein vergebenes Admin Kennwort wurde später bei der Gasterweiterung nicht akzeptiert. (Ich kämpfe im Augenblick sehr zeitintensiv mit "disk verification error" bei einem sehr alten Programm auf meinem alten Medion WINXP Rechner).

 

Gruß

Klaus

 

Nachricht 4 von 12
1.233 Aufrufe
Nachricht 4 von 12
1.233 Aufrufe

Re: Linux-Installation Fedora 24 XFCE x86_64 auf Akoya P5320 E im UEFI-Modus mit Secure-Boot

moin KlausX...

richtig... da ich jedoch explizit win_proggies (mit allen feinheiten a lá masterC6&co) - die mit wine halt probs haben/haben könnten (bzw. es nicht sooo einfach wäre) ;-)

für mich war ausschlaggebend -> plain linux! - strom sparend und sicher ;-)

mal ubuntu probiert? (mein Odroid-C2 läuft damit prächtig).

warum einen 'stromfressenden' rechner dafür nutzen - wenn es auch anders geht? ;-)

der unterschied zu meinem NB -> Odroid liegt bei guten 24 watt (ich meine damit nicht NB mit 18,4" & 27" und spielen - sondern die normale nutzung).

von VMs habe ich halt aus o.g. gründen dann eher abstand genommen (ausser kaputtem apfel - zum testen)...

aber jeder wie mag & grüssinx

 

Nachricht 5 von 12
1.230 Aufrufe
Nachricht 5 von 12
1.230 Aufrufe

Re: Linux-Installation Fedora 24 XFCE x86_64 auf Akoya P5320 E im UEFI-Modus mit Secure-Boot

@KlausX

bzgl. dem Admin-Kennwort,

es kann sein, dass beim Anmeldedialog ein anders Tastaturlayout eingestellt ist, als das welches damals für die Passworteingabe benutzt hast. Aber dort kann man das Tastaturlayout auch ändern, also mal ggf. englisch(US) einstellen.

Nachricht 6 von 12
1.213 Aufrufe
Nachricht 6 von 12
1.213 Aufrufe

Re: Linux-Installation Fedora 24 XFCE x86_64 auf Akoya P5320 E im UEFI-Modus mit Secure-Boot

Hallo Kill_Bill,

 

bezüglich Virtualbox WIN10 Host mit Fedora24 als Gast:

es ist ein bischen irritierend, wenn bei der Installation nur das Password als notwendig gekennzeichnet ist. Ich habe nochmal neu mit Benutzernamen und Password installiert, dann ging das. Dann kam allerdings das Problem mit der Gasterweiterung.

Bei Linux-Fedora geht das nicht einfach über das Menü der virtualbox, sondern nach dieser Anleitung:

https://thomas-leister.de/virtualbox-guest-additions-fuer-fedora-installieren/

Dabei gab es erst mal 681 Aktualisierungen.

Dann ist die Erweiterung auch installiert, wenn man die ISO Datei unter Massenspeicher sehen kann. Mit einigen Klickversuchen habe ich dann auch die Anpassung des Bildschirms hinbekommen. Mit viel Recherche im Netz und dem Fazit, dass Linux nach wie vor nichts für mich ist. Vielleicht mal mit entsprechenden Kommandos, um in speziellen Windows Situationen vorwärts zu kommen.

 

Gruß

Klaus

 

Nachricht 7 von 12
1.199 Aufrufe
Nachricht 7 von 12
1.199 Aufrufe

Die proprietären Nvidia Treiber für die GF 750 Ti installieren, im UEFI Secure-Boot Modus.

Der nouveau Grafiktreiber ist nicht so ausgereift, wie der aktuelle proprietäre Grafiktreiber von NVIDIA,
auch was Video-Hardwarebeschleunigung betrifft, aber auch, OpenGL-Anwendungen und Spiele sollten damit auch schneller laufen.
Daher will man den wohl noch nachinstallieren, immerhin hat man ja eine recht potente GF 750 Ti Grafikkarte im Rechner, deren Potential man nicht brach liegen lassen will.

 

Am einfachsten geht das über rpmfusion mit akmod (im Root-Terminal):
siehe: http://forums.fedoraforum.org/showthread.php?t=310949

#dnf install https://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm https://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm

#dnf install xorg-x11-drv-nvidia akmod-nvidia "kernel-devel-uname-r == $(uname -r)"

#dnf update -y

Noch keinen Neustart machen, wenn doch, muss man dann in der Konsole (Öffnen mit ALT+F2) weiter arbeiten!

So, leider sind diese Nvidia-Treiber nicht von Fedora für UEFI Secure-Boot signiert, mit dem selben Key wie der Kernel, und deshalb laden diese Kernel-Module für die Nvidia-Grafikkarte mit UEFI Secure-Boot nicht.
Aber das kann man beheben, indem man diese installierten Module mit einem selbst erstellten privaten Schlüssel selbst signiert. Und diesen dazupassenden öffentlichen Schlüssel importiert man in das UEFI-BIOS.

Wie das funktioniert, hat ein gewisser Laurent Pellegrino netterweise hier beschrieben:
http://www.pellegrino.link/2015/11/29/signing-nvidia-proprietary-driver-on-fedora.html

Habe das nach der Anleitung durchgeführt, und es ist wirklich nur halb so wild, wie es zuerst klingt. Ist halt zusätzliche Arbeit, jedes mal, wenn man neuen Kernel installiert/updatet.
Beim aktuellen Nvidia-Treiber gibt es nun nicht nur 2, sondern 4 Module zum Signieren: nvidia-drm.ko nvidia.ko nvidia-modeset.ko nvidia-uvm.ko !

(also vom Verzeichnis der Treiberdateien aus /lib/modules/4.8.6-201.fc24.x86_64/extra/nvidia )

#/usr/src/kernels/4.8.6-201.fc24.x86_64/scripts/sign-file sha256 /root/Signing-Modules-UEFI-OPENSSL/private_key.priv /root/Signing-Modules-UEFI-OPENSSL/public_key.der nvidia.ko

 

Die Keys, vor allem den privaten, gut aufheben, vielleicht mit p7zip 7za verschlüsselt speichern, und wo ein Backup machen. Den braucht man dann beim nächsten Treiber- oder Kernelupdate wieder, um diese dann neu kompilierten Treiberdateien ebenfalls zu signieren.

 

Den öffentlichen Schlüssel mit mokutil in das UEFI  importieren funktioniert entgegen der Anleitung jetzt auch problemlos.
#mokutil --import public_key.der


Man muss dafür ein Passwort eingeben, und wenn man den Rechner neu startet, kommt eine UEFI-Konsole, bei der man das importieren des eigenen Keys dann bestätigen kann, man muss das Passwort dann nochmals eingeben.

Bei mir gab es noch einen eigenartigen Fehler, es wurde von Xorg nicht das nvidia libglx.so geladen,
daher funktionierte zB. auch $ glxgears nicht. Eigentlich sollte die Treiberinstallation mit akmod sich darum sorgen.
Also in /etc/X11/xorg.conf mit nano editor eine Modules section hinzufügen und das Modul explizit laden.


Section "MODULE"
Load "/usr/lib64/nvidia/xorg/libglx.so"
EndSection


Abschließend kann man mit den Nvidia-Systemeinstellungen div. Grafikoptionen genauer anpassen.
Und in den XFCE "Feineinstellungen der Fensterverwaltung" "Zeichnen mit der vertikalen Austastlücke synchronisieren" aktivieren.

http://666kb.com/i/de4a9k0b8hu92z2yx.png

Damit sollten beim Scrollen und Verschieben von Fenstern die Fransen und Verzerrungen verschwunden sein.

 

Nachricht 8 von 12
1.081 Aufrufe
Nachricht 8 von 12
1.081 Aufrufe

Re: Die proprietären Nvidia Treiber für die GF 750 Ti installieren, im UEFI Secure-Boot Modus.

Wenn das sog. "screen tearing" noch nicht zuverlässig ganz weg ist, mit den zuvor gemachten Einstellungen (die an sich ja korrekt sind),

kann man zusätzlich dieses Kommando anwenden, um dem nvidia-treiber korrekt einzustellen:

 

#nvidia-settings --assign CurrentMetaMode="nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"

Dann auf der Seite testen, ob es nun auch korrekt funktioniert:

http://www.vsynctester.com/

 

Man kann diese Zeile (nach dem #) in seinem home-Verzeichnis mit nano der .bash_profile am Ende hinzufügen,

damit sie beim Einloggen jedesmal automatisch ausgeführt wird.

Nachricht 9 von 12
878 Aufrufe
Nachricht 9 von 12
878 Aufrufe

Re: Linux-Installation Fedora 24 XFCE x86_64 auf Akoya P5320 E im UEFI-Modus mit Secure-Boot

Schade, die Respins für Fedora24 wurden vom Server geworfen, und durch Respins von Fedora 25 ersetzt. Falls man jetzt noch Fedora24 installieren will, muss man wohl das alte Image vom Release holen, und nach Installation sofort alles updaten.

 

http://fedora.inode.at/releases/24/Spins/x86_64/iso/

Highlighted
Nachricht 10 von 12
839 Aufrufe
Nachricht 10 von 12
839 Aufrufe

Re: Linux-Installation Fedora 24 XFCE x86_64 auf Akoya P5320 E im UEFI-Modus mit Secure-Boot

moin ;-)

 

ohhh... fehler in meinem post #4 ;-)

 

Zu meinem Post hier #4

 

bezüglich
"der unterschied zu meinem NB -> Odroid liegt bei guten 24 watt (ich meine damit nicht NB mit 18,4" & 27" und spielen - sondern die normale nutzung)."

Odroid liegt bei 5 Watt ;-)

sorry...

grüssinx